Home
Accesso / Registrazione
 di 

AD7730(L) e clock (quarzo a frequenza doppia)

Per errore ho montato un AD7730L con un quarzo da 4.9152 MHz (invece dei
2.4576 previsti dalla versione L).
Nell'attesa di ricevere il nuovo quarzo volevo comunque iniziare a
pasticciare con la scheda...

Ma l'oscillatore non oscilla... domanda: secondo voi è plausibile visto
che sto utilizzando un quarzo con frequenza doppia rispetto a quella
prevista?

Io mi sarei aspettato ugualmente l'oscillazione ma una degradazione
delle prestazioni. Infatti il datasheet dice:

Master clock range for AD7730L: 1 to 5 MHz

The AD7730L is specified with a clock input frequency of 2.4576 MHz

Quindi utilizzare un quarzo entro i 5 MHz sulla versione L dovrebbe
essere consentito pur senza garanzia di avere le prestazioni indicate, o
sbaglio?

Come potrei fare per indagare sulla causa della mancata oscillazione?

 

 

Scrivi un commento all'articolo esprimendo la tua opinione sul tema, chiedendo eventuali spiegazioni e/o approfondimenti e contribuendo allo sviluppo dell'argomento proposto. Verranno accettati solo commenti a tema con l'argomento dell'articolo stesso. Commenti NON a tema dovranno essere necessariamente inseriti nel Forum creando un "nuovo argomento di discussione". Per commentare devi accedere al Blog
ritratto di elettronica_generale

Re: AD7730(L) e clock

Oppure usare il quarzo da 4.9MHz attaccato ad un CD4060 ed usare il
clock prescalato iniettandolo nell'AD7730L togliendo ogni dubbio.

ritratto di elettronica_generale

Re: AD7730(L) e clock

Immagino che ne sarai già al corrente, ma occhio che appoggiando il
puntale sui terminali del quarzo l'oscillatore può spegnersi a causa
della capacità addizionale dovuta alla misura. Se puoi, usa una sonda
attenuatrice, oppure vai in cerca del segnale con un piccolo loop,
oppure ancora cerca segni indiretti della possibile oscillazione.

ritratto di elettronica_generale

Re: AD7730(L) e clock

Di suo la versione "L" dovrebbe avere la soglia di 2.4576 MHz.
D'altro canto, è bene controllare l'impostazione del bit "CLKDIS" nel
"Mode Register": deve essere a zero sennò non oscilla.

 

 

Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ci sono attualmente 3 utenti e 22 visitatori collegati.

Ultimi Commenti