Home
Accesso / Registrazione
 di 

[aiuto] clap-switch per macchina fotografica

23 risposte [Ultimo post]
ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75

Ciao a tutti, dopo aver chiesto e ottenuto moltissimo aiuto su un caricabatterie solare, sono di nuovo qui a elemosinare consigli! :) Un annetto fa mi sono avvicinato all'elettronica, senza alcuna base, neppure teorica, ma con un progetto in mente: essendo appassionato di fotografia, avevo intenzione di costruirmi un trigger per la macchinetta, che me la facesse scattare in due modalità: quando rileva un rumore, come un bicchiere che va in frantumi; quando un fascio laser viene interrotto. Arduino è stata la prima scelta, perché era più intuitivo, e infatti con qualche mese di prova e riprova ho portato a termine il progetto con Arduino. Mi sono però reso conto che un microcontrollore è un po' sprecato per la cosa che vorrei fare io, quindi adesso che ho un po' (pochissimo) di conoscenze in più, vorrei realizzare la stessa cosa con un 555, anche per capire come funziona questo integrato. Per prima cosa l'ho configurato come monostabile, in modo che alla pressione di un pulsante collegato fra il pin2 e GND mi facesse accendere un led per un tempo (3 secondi circa) determinato da R1 e C1. poi ho aggiunto al pin 3 anche un fotoaccoppiatore, con cui mettere in corto il tasto della macchina fotografica, e fa esattamente ciò che voglio io: quando premo, scatta, per 3 secondi rimane in stand-by con il led acceso, e poi è pronto per scattare di nuovo. Ora, ho provato a sostituire il pulsante con una capsula microfonica, riarrangiando il circuito come meglio ho potuto, ma anziché scattare quando rileva un rumore, è come se il pin 2 fosse sempre a massa, quindi il led è acceso, come se ricevesse un impulso continuo. qui sotto potete vedere lo schema del circuito che ho montato, forse qualcuno può aiutarmi a capire dove sbaglio! 

Grazie a tutti, 

Antonello

ritratto di Marven
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
19 settimane 1 giorno fa
Utente dal: 14/04/2013
Messaggi: 146
Utente PREMIUM
Ciao Antonello non riesco a

Ciao Antonello
non riesco a visualizzare lo schema
Ciao
Mario

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Buon pomeriggio, Mario, prova

Buon pomeriggio, Mario,
prova con questo Link! :)

http://imageshack.us/photo/my-images/692/p9kw.png/

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
34 min 54 sec fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
Possibile modifiche

Ciao Antonello

La tua idea di non usare la scheda Arduino è buona ma considera che puoi sempre creare un “Arduino stand alone” formato dal solo processore e poco altro.
In questo modo, puoi sfruttare la potenza del processore senza spendere molto, vedi per esempio questa applicazione presente sul mio sito
http://www.adrirobot.it/arduino/arduino_stand-alone/arduino_stand-alone.htm
A parte questo ho cercato un po’ in rete e ho trovato un circuito simile al tuo.
http://www.doc-diy.net/photo/sound_trigger/
La differenza sembra la mancanza del condensatore C4, poiché l’uscita del transistor T1 è subito collegata all'ingresso Trigger.
E’ poi presente un trimmer R1 per la modifica della polarizzazione del transistor.
Anche la sezione che regola la durata dell’impulso è diversa, devi verificare con i valori che hai impostato la sua effettiva durata, nel caso inserire un trimmer com'è riportato nell'altro schema.
Spero di esserti stato utile.
Un saluto
Adriano

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao Adriano, dunque, mettere

Ciao Adriano,
dunque, mettere il microcontrollore in standalone è proprio ciò che ho fatto: dopo mesi di prove su breadboard (come ho scritto, partivo proprio da 0) ero riuscito a programmare un atMega328 e a far funzionare il tutto in maniera completamente indipendente dalla scheda Uno. Poi, nel momento di fissare tutto su millefori, qualcosa deve essere andato storto nella saldatura, perché non funzionava più. Essendo quello il mio primo progetto, ed essendo anche la 2a volta che toccavo un saldatore ho sicuramente fritto qualche componente. Quando (dopo lo sconforto iniziale :D) mi sono deciso a rimetterci le mani ho pensato alle potenzialità di Arduino, e alle mie tutto sommato ridotte esigenze, quindi mi sono detto: vediamo se riesco a farlo più semplice, con meno componenti e più piccolo, male che vada riprovo con la versione basata su Arduino, che tanto è lì pronta!! :) quindi eccomi qui a litigare col 555 :D
Dunque, sì, mi pare che l'unica differenza col mio sia quel condensatore e il fatto che lui alimenta il tutto a 5 anziché a 9v, quindi i valori potrebbero essere diversi per quello. Un'altra cosa: siccome su internet si trovano miriadi di circuiti per amplificare una capsula microfonica, ma non ce ne sono due che lo fanno nella stessa maniera, io ho replicato quello con i valori più simili ai componenti che ho... Ma come si fa a decidere le dimensioni, ad esempio,delle resistenze da mettere ai capi del transistor? come decido la resistenza del potenziometro per settare la soglia oltre la quale il segnale parte e la macchinetta scatta?
Grazie,
Antonello

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
34 min 54 sec fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
Dimensionamento circuiti

Ciao Antonello
Per la versione stand Alone, il processore rimesso sulla scheda Arduino funziona ancora?
Se è così, potrebbe essere sono un problema di circuito.
Darti invece una risposta in poco righe su come dimensionare un circuito, è un’altra questione.
Non so che percorso di studi hai fatto o stai facendo. Se avessi fatto qualche lezione di elettronica, sapresti che per far funzionare un transistor come amplificatore, nel nostro caso deve amplificare il debole segnale fornito dalla capsula microfonica.
In questo caso forse ti sarebbe di aiuto Vittorio Crapella, anche lui utente di questo sito, dove nel suo sito personale oltre ad un’infinità di utili circuiti si trovano molte pagine tecniche tra cui:
http://www.webalice.it/crapellavittorio/labo/ampli_bc.html
Dove è spiegato come dimensionare la rete di polarizzazione di un transistor. Come vedrai, non è semplice e non sempre utilizzare quello che si possiede in casa porta ai risultati sperati.
La stessa cosa vale per l’integrato NE555, i cui valori devono essere calcolati con formule che sono riportate nella scheda tecnica, anche in questo caso il sito di Vittorio è ricco di schemi che lo utilizzano.
http://www.webalice.it/crapellavittorio/electronic/ne555_schemi.html
In rete esistono poi molti siti che permettono il calcolo dei valori on-line, per esempio il primo che ho trovato.
http://www.royalrife.com/555_calculator.html
Saluti
Adriano

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Buona domenica,

Buona domenica, Adriano,
Nonostante gli abbia spezzato il pin 14 per farlo uscire dallo zoccolo, il processore funziona, ne sono sicuro, perché quel pin non mi serviva e perché dopo aver constatato che la versione saldata non funzionava l'ho rimesso sulla breadboad, ho ritestato il tutto e andava... Quindi quasi sicuramente ho sbagliato a connettere qualcosa (anche se ad essere sincero non mi sembra) o ho rovinato qualcosa col saldatore troppo caldo...
Ad ogni modo: il mio corso di studi non mi aiuta affatto questo campo, perché sono uscito dal classico e studio giurisprudenza. Quelle 3 cose che so di elettronica sono frutto di studio nei ritagli di tempo tra un esame e l'altro! :) ho dato una letta alla pagina di Vittorio Crapella, e mi sembra molto utile, grazie della segnalazione, sicuramente appena possibile la leggerò con un po' di attenzione, ma sicuramente avrò bisogno di aiuto. Anche gli esempi di circuiti col 555 sono tantissimi e offrono parecchi spunti!
Dopo pranzo credo che riproverò ad amplificare la capsula, vi farò sapere!
Ciao e grazie!

ritratto di Ivan Scordato
Online
Titolo: PowerUser
Utente Power
Ultima visita:
27 min 31 sec fa
Utente dal: 30/09/2012
Messaggi: 380
Utente PREMIUM
Ciao, sono MOLTO d'accordo

Ciao, sono MOLTO d'accordo con te :)

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao Ivan! Su quale punto

Ciao Ivan!
Su quale punto esattamente sei d'accordo? :D
Dunque, ieri mi sono rimesso sul circuito, sono riuscito a farlo scattare grazie al suono, ma ad una soglia fissa. Adesso dovrei inserire il potenziometro per regolare la sensibilità. Voi direte: e che ci vuole? Ecco, sarà una domanda stupida, ma mi ci sto scervellando... dallo schema di questo link http://www.doc-diy.net/photo/sound_trigger/ non riesco a capire come devo cablare il pot... ho provato in diversi modi, ma non sembra funzionare più di tanto: l'unico risultato che ho ottenuto è che adesso il led sul mio circuito si comporta così: muovendo il potenziometro, a 0 è spento, verso la metà corsa si accende gradualmente, poi si spegne gradualmente, per rimanere spento fino a fine corsa... Non è esattamente quello che volevo, io dovrei usare il pot per decidere la soglia oltre la quale il transistor mi "triggera" tutto l'affare... Vorrei capirlo anche per saper usare un potenziometro in altre occasioni senza impazzire! Help please! :D
Ciao a tutti,

Antonello

P.S. immagino già che appena qualcuno mi spiegherà come fare dirò "ah già, che scemo!!" :P

ritratto di Ivan Scordato
Online
Titolo: PowerUser
Utente Power
Ultima visita:
27 min 31 sec fa
Utente dal: 30/09/2012
Messaggi: 380
Utente PREMIUM
Ciao Antonello. Bhè... dicevo

Ciao Antonello.
Bhè... dicevo che sono d'accordo con adrirobot che ti ha consigliato di realizzare un arduino standalone per realizzare questo tuo progetto senza bisogno di scervellarti. :)
Dimmi un pò... come hai collegato il potenziometro?

Praticamente quello che avresti dovuto fare è di aggiungere il potenziometro nel seguente modo:
Al posto della resistenza R5 (esattamente quella da 20k ohm) colleghi un potenziometro da 250K.
In questo modo puoi variare il trigger nel NE 555.
Prima di tutto dovresti scegliere una frequenza del trigger bassa (50k - 100k)e dopo lentamente puoi aumentare R5 (il potenziometro) fino a quando saturerai il circuito. Dopo la saturazione devi resettare il circuito cortocircuitando R1.

Hai fatto così?

Spero di esserti stato utile,
Ivan

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao a tutti, scusate il

Ciao a tutti, scusate il ritardo, soprattutto tu, Ivan, che mi avevi risposto all'ultima domanda! Per l'Arduino in standalone ti rimando al mio post in risposta ad Adriano, dove spiego i motivi per cui ho scelto di "impazzire" col 555! :D
Allora, mi sono dedicato un po' al circuito stasera, e ho risolto il problema. So che di sicuro non era tua intenzione ma appena letto la tua risposta avevo le idee più confuse di prima: infatti stavo seguendo lo schema sul sito doc-city, e lì dice che il pot è R1 ed è da 100K!!! Perché dici che avrei dovuto sostituire R5?
Comunque il mio problema era proprio di cablaggio, non sapevo quale pin del potenziometro dovevo collegare e a che cosa, perché dallo schema sembra quasi (correggimi se sbaglio) che i due terminali esterni del potenziometro R1 siano collegati uno alla base del transistor e uno a massa, e il centrale anche lui a massa. Ecco perché non mi tornava. Però ora ho fatto due cose: innanzi tutto ho comprato un po' di resistenze per avere i giusti valori di che mi servivano per seguire lo schema (invece di fare con i valori che già avevo, che non corrispondevano) e ho collegato così il potenziometro: il 1° pin all'uscita di c3, il 2° alla base del transistor (ho usato un BC547) e il 3° a massa. Adesso il circuito funziona, il potenziometro decide effettivamente il punto oltre il quale far scattare il tutto.
Grazie a tutti!! :)

Antonello

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
34 min 54 sec fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
Collegamento di un potenziometro/trimer

Per il cablaggio dei potenziometri o trimmer devi considerare che questi come hai visto hanno tre terminali, i due laterali rappresentano la resistenza mentre il centrale è il cursore mobile.
Se ti serve solamente una resistenza variabile cortocircuiti, un lato del trimmer con il cursore e questo è un lato della resistenza, l’altro è il terminale variabile.
A questo punto ruotando il perno, il valore di resistenza varierà.
Secondo quale lato hai utilizzato, il valore ruotando il trimmer per esempio in senso orario potrà aumentare o diminuire.
Un altro montaggio è quello in cui per esempio un lato del trimmer è collegato al positivo, l’altro al negativo dell’alimentazione, a questo punto dal terminale centrale potrai prelevare una tensione variabile dal valore massimo dell’alimentazione sino a zero, poiché il trimmer si comporta come partitore.
Un esempio di quest’ultimo utilizzo è per fornite una tensione all’ingresso analogico di Arduino.
http://arduino.cc/en/Tutorial/AnalogInput
Saluti
Adriano

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Tra l'altro, avrei ancora un

Tra l'altro, avrei ancora un paio di domandine, se qualcuno volesse essere così gentile... So che vi sto tediando, ma se riuscissi a capire qualcosa in più sarebbe una grande soddisfazione, per me che fino all'anno scorso credevo che chi si occupa di elettronica avesse frequentato Hogwarts! :)
La prima domanda è: come faccio a capire di che resistenza mi serve un potenziometro? Cioè come faccio a sapere se ci va un pot da 10, 20 o 100 kOhm? C'è qualche formula matematica che può essere utile?
Seconda domanda: mi sono messo a sperimentare, del tipo "che succede se cambio questo?". Ho notato che mettendo una resistenza più grande (10k) al posto di R4, che è da 2.2k mi diventa un po' più sensibile, cioè mentre prima captava un battito di mani a circa 30 cm, adesso anche da un metro e più di distanza non ha problemi, anche se non batto fortissimo (i vicini dormono :P). Come mai? come influisce R4? dall'idea che mi ero fatto, essendo una resistenza più grande dovrebbe far passare meno corrente, quindi farne arrivare meno al microfono... no?

Buona serata

Antonello

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
34 min 54 sec fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
E bravo Antonello Non ti sei

E bravo Antonello
Non ti sei dato per vinto e sei stato premiato.
Per la domanda sul potenziometro, il calcolo del valore dipende dal circuito in cui va inserito.
Di solito si trova il valore e poi se questo deve essere variabile, per esempio per aumentare la sensibilità o l’amplificazione si sostituisce il valore fisso con un potenziometro o un trimmer il cui valore permette di variare quello teorico entro un certo range.
Per quanto riguarda il fato che variando il valore di R4 cambi la sensibilità, devi considerare che quella resistenza fa parte di un circuito, per cui devi considerare per esempio che R4 che è sul ramo di alimentazione della capsula microfonica, è anche in parallelo a R6, e questa serve alla polarizzazione della base del transistor insieme al trimmer R1.
Perciò variando il suo valore, probabilmente varia anche l’amplificazione, occorre sempre considerare l’interdipendenza dei componenti.
Saluti
Adriano

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao Adriano, grazie della

Ciao Adriano, grazie della spiegazione, non avevo pensato all'interdipendenza dei componenti, d'ora in poi terrò a mente anche quella, magari in seguito mi aiuterà a capire meglio come funziona un circuito!
Ringrazio tutti del prezioso aiuto, il circuito adesso funziona perfettamente e sono pronto per andare avanti: infatti il progetto che avevo fatto con Arduino prevedeva anche l'uso di una fotoresistenza e un raggio laser, per far scattare la macchinetta quando il raggio viene interrotto. Muovendo un deviatore potevo mettere il dispositivo in modalità laser o audio e usare quello che mi serviva, adesso voglio vedere se riesco a replicare anche l'altra parte incorporandola a quello che ho già. Quello che mi serviva a dire il vero era l'attivazione audio, ma siccome avevo a disposizione il microcontrollore avevo deciso di allargarmi un po'! Adesso che la parte audio funziona posso dedicarmi alla parte ad attivazione laser, e questo significa che siccome siete stati gentilissimi, presto sarò di nuovo qui a disturbare! :D Anzi, comincio subito: quello che ho in mente è fattibile con un solo 555 o è meglio che ne usi un altro, o che passi a un 556?
Grazie, buona serata,

Antonello

ritratto di Ivan Scordato
Online
Titolo: PowerUser
Utente Power
Ultima visita:
27 min 31 sec fa
Utente dal: 30/09/2012
Messaggi: 380
Utente PREMIUM
laser e fotocellula

Ciao, si è possibile.
Per lo scopo devi utilizzare un diodo laser ed una fotocellula.
A presto,
Ivan.

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao a tutti

Ciao a tutti ragazzi,
rispolvero questo thread dopo un bel po' di tempo per dirvi due cose: intanto ero arrivato alla soluzione di mettere nel circuito solo l'attivazione sonora, e di fare un circuito separato per il laser, quindi mi ero dedicato alla disposizione dei componenti sulla millefori. Siccome però Adriano mi aveva messo la pulce all'orecchio, ho aspettato un po' per documentarmi sui pcb fai da te, ho comprato l'occorrente e ho realizzato direttamente lo stampato! sono contento perché oltre a essermi divertito tantissimo a farlo, ed essere soddisfatto per come si presenta esternamente ho imparato un po' di cose nuove. C'è solo un problema: quello che sulla breadboard funzionava ora non fa ciò che dovrebbe. Dunque, io ho seguito lo schema che vi linko di seguito, e ho disposto i componenti e le piste come vedete nel secondo link. Mi pare che vadano bene le connessioni, (secondo voi?) ma il circuito non va. Ho pensato che magari potevo aver fatto delle saldature fredde, ma controllandole con il test di continuità non mi pare che ce ne siano. Quindi ho pensato che potesse essere qualche ponte indesiderato fra le piste: in effetti il multimetro mi segna un minimo di continuità tra piste che non dovrebbero averne, (non fischia sempre, ma compaiono numeri diversi da 1). Le ho ricontrollate sotto una lente, ma sono ben separate. Allora mi è venuto un lampo: pulendo la pcb appena fatta dal toner residuo, questo ha sbavato e ha sporcato parte della scheda. Non è che il toner è conduttivo e inficia le connessioni? C'è qualcosa che posso fare o mi conviene rifare la pcb da capo?
Schema: https://imageshack.com/i/10kme6p
Board: https://imageshack.com/i/g9ctkup

Grazie a tutti!

Anto

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
34 min 54 sec fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
Verifica circuito

Ciao Antonello

Facendo le misure di continuità con i componenti montati i valori sono falsati. La misura di isolamento andrebbe fatta prima di saldare i componenti.

Se la basetta è stata pulita e il toner eliminato prima di saldare i componenti non ci sono problemi.

Utilizzando il comando "ECR" Electrical Rule Check di EAGLE, ti segnala degli errori?

Ma il circuito montato sulla Breadbord e lo stesso che hai utilizzato per il CS?

Puoi inserire anche delle foto della basetta?

Saluti
Adriano

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao Adriano, grazie della

Ciao Adriano, grazie della risposta! :)
Dunque: sì, il circuito è lo stesso, e su Eagle avevo fatto il controllo errori ma non me ne segnalava... Non sapevo che la misura potesse essere falsata una volta saldati tutti i componenti.
Allego le foto della basetta, lato componenti e lato rame. A vederla sono abbastanza soddisfatto di come è venuta perché è la prima che faccio (anzi la seconda, la prima l'avevo disegnata a mano per provare il cloruro). Solo che se non funziona è solo un piccolo soprammobile! :P
Se può servire posso allegare anche il file dello schema di Eagle, magari è più facile da controllare rispetto alle foto

Lato componenti: https://imageshack.com/i/g9bd74j
lato rame: https://imageshack.com/i/nhsiaxj
N.B. dove ci sono i numeri 1 e 2 è per segnalare che anche se non sembra le piste sono isolate, non ci sono ponti. Le ho controllate con un monocolo da orologiaio! :)
Come puoi vedere il toner non è venuto via del tutto, perché mentre la pulivo con l'acetone ha sbavato e non sono riuscito a toglierlo dalla vetroresina... appena ho un attimo rimonto il tutto su breadboard e riprovo, per sicurezza.
Grazie comunque dell'aiuto! :)

Un saluto e buona giornata,

Anto

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
34 min 54 sec fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
Interventi migliorativi

Ciao Antonello
Come tua seconda basetta non è terribile, anche se ci sono spazi di miglioramento :-)
Ti consiglierei eventualmente di "ripassare" i punti di possibile contatto con una lama di taglierino.
Per la pulizia dei resti di flussante puoi utilizzare della trielina, che viene utilizzato come smacchiatore.
Vedi anche il mio articolo Come saldare i componenti elettronici con una stazione di saldatura digitale.

 

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Grazie Adriano, il tuo

Grazie Adriano,
il tuo articolo è molto utile, infatti lo avevo già letto! :)
Ho già ripassato con il bisturi da modellismo gli spazi di contatto, infatti se ci fai caso in alcuni punti la basetta è rigata!
Quindi tu cosa mi consigli di fare? devo rifare lo stampato, provare a vedere cos'è che non va in questo o rivedere lo schema?
Grazie mille,

Anto

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ciao a tutti, finalmente ho

Ciao a tutti,
finalmente ho un po' di tempo libero dagli esami, quindi mi posso dedicare un po' di più al circuitino! stasera mi è venuto un dubbio: dato che non riesco a trovare cosa ci sia che non va nelle piste della pcb, ho pensato ce magari potevo aver cotto il transistor mentre lo saldavo... Mi sono documentato e ho visto che si possono provare e vedere se funzionano con l'aiuto di un multimetro, ma la regola vale anche per transistor che sono già stati saldati? O anche in questo caso la misura è falsata? perché tutte le combinazioni che provo coi puntali mi danno sempre più o meno 1,2 MOhm di resistenza... sbaglio qualcosa? Potrei risolvere dissaldando e sostituendo il transistor secondo voi?
Grazie a tutti!

Anto

ritratto di Antonello.90
Offline
Titolo: User++
Utente++
Ultima visita:
8 settimane 19 ore fa
Utente dal: 17/10/2013
Messaggi: 75
Ragazzi, ciao a tutti. Forse

Ragazzi,
ciao a tutti. Forse vi siete scordati di questo progettino, ma io lo ripesco, per dirvi che finalmente funziona. Non si trattava del transistor o di altri componenti bruciati, ma di un collegamento che non avrebbe dovuto esserci. Stavo riesaminando lo schema che avevo fatto con Eagle, del quale ero sicuro che fosse giusto, e d'un tratto mi sono accorto che (non so come) Eagle aveva dato lo stesso nome alle connessioni che andavano al pin 3 e al 5, quindi le leggeva come se fossero un'unica pista. Questo si è tradotto in una pista in più che metteva in corto il pin 3 e il 5, che non avrebbe dovuto esserci, ma che l'autorouter ha fatto. Siccome non avevo molto da perdere, ho ritirato fuori la pcb che avevo fatto, ho interrotto quella pista e adesso va tutto come deve!! :D
Quindi occhio ai nomi delle connessioni con Eagle! :D
Un saluto e grazie ancora a tutti dell'aiuto!

Anto

ritratto di Ernesto.Sorrentino
Offline
Ultima visita:
2 giorni 4 ore fa
Utente dal: 07/03/2014
Messaggi: 1
Utente PREMIUM
Smart trigger

Ciao Antonello, sono un nuovo utente e per tanto ti rispondo solo adesso. Anch'io sono appassionato alla fotografia e progettazione elettronica, nel 2012 progettai un trigger con molteplici funzioni utilizzando un PIC, ti posto il link http://www.dgvelab.com/photography/trigger/.
Se ne hai bisogno ho ancora dei PCB e la skin in PVC.
Ciao.

 

 

Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ultimi Commenti