Home
Accesso / Registrazione
 di 

Collegamento Raspberry a Contatore elettrico tramite smart meter SD0 busware

2 risposte [Ultimo post]
ritratto di jakdanielz
Offline
Titolo: User
Utente
Ultima visita:
41 settimane 6 giorni fa
Utente dal: 16/11/2013
Messaggi: 2

Ciao a tutti,
premetto che di elettronica so poco e scrivo per chiedere aiuto su come far funzionare una scheda di espansione per raspberry, per la registrazione dei consumi elettrici, collegabile ad un contatore compatibile allo standard DIN 43864, co uscita ad impulsi.

L'impianto è costituito di
- 1 raspberry
- 1 schda di espansione busware smart meter sd0 (per lettura uscita inpulsi DIN 43864)
- 2 contatori elettrici standard DIN 43864 (DMMetering DRM-75RR e Electrex CD1. Al momento sto sperimentando solo col CD1)

Ho collegato il canale 1 della scheda di espansione agli ingressi del contatore cd1 in questo modo

scheda espansione rapberry
CHANNEL 1
+ -
| |
| |
| |
+ -
4 5
contatore CD1

Ho seguito le istruzioni fornite sul sito della scheda di espansione per l'installazine e la compilazinoe del firmwre, ma usando il programma in dotazione non vedo alcuna registrazione dei tick degli inpulsi sul raspberry, tramite il programma indicato nella documentazione.

Gli schemi della scheda di espansione e le specifiche del contatore Electrex CD1 (oltre a pagine descrittive) sono indicate qui di seguito.
http://busware.de/tiki-download_file.php?fileId=69
http://www.electrex.it/download/category/33-discontinued.html?download=100%3Aistruzioni-in...
http://busware.de/tiki-index.php?page=SD0
http://busware.de/tiki-index.php?page=SD0_Installation
http://www.electrex.it/prodotti/contatori-analizzatori/pfe500-00.html

Non capisco se sbaglio qualcosa nel collegameto o se qualcuno dei componenti sia guasto.

Se qualcuno potesse aiutarmi a capire dove sbaglio, gliene sarei molto grato.

Grazie

Eugenio

ritratto di adrirobot
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
2 giorni 18 ore fa
Utente dal: 04/06/2013
Messaggi: 113
Utente PREMIUM
Problema di interfaccia per Raspberry

Ciao Eugenio
Vedo che ti sei appena iscritto e questo è il tuo primo messaggio, per cui ti porgo il benvenuto in nome della comunità.
Non conosco l’interfaccia che hai utilizzato, ho dato un’occhiata in rete e ho visto che non ha molta diffusione per cui non si trovano informazioni su altri che abbiano avuto il tuo stesso problema.
Per questo darti aiuto, risalire alle origini del problema è difficile, quello che ti consiglio, è in primis di procedere in via preliminare all'aggiornamento del sistema operativo della scheda, e poi di riprovare a eseguire le varie fasi dell’installazione, esaminando che non appaiano eventualmente dei messaggi di errore durante l’installazione.
Nel caso non risolvessi, proverei a inviare eventualmente una richiesta al costruttore, tenendo d’occhio eventualmente la pagina dei FAQ
http://busware.de/tiki-list_faqs.php
Un saluto
Adriano

ritratto di jakdanielz
Offline
Titolo: User
Utente
Ultima visita:
41 settimane 6 giorni fa
Utente dal: 16/11/2013
Messaggi: 2
Ciao Adriano, grazie per il

Ciao Adriano,
grazie per il benvenuto :-)

Ho gia' contattato il sig. Tostmann (che è il responsabile del sito della busware) il quale pero' alla prima mia mail non ha risposto, mentre alla seconda mi arriva un autorisponditore che è in ferie fino al 26. Attendo.

Ho inoltre contattao anche un'altro ragazzo che aveva quell'interfaccia, che aveva scritto su un forum tedesco scritto in tedesco (knx), il quale mi ha confermato che a lui funziona correttamenrte collegando come ho descritto io.In seguito poi ho anche verificato il funzionamento del contatore di energia prima tramite tester e successivamente tramite connessione diretta sul raspberry e funziona.

Ho rieseguito piu' volte l'installazione del firmware e successivamente verificato l'uscita 24v dai connettori che vanno al contatore.

Attendo quindi notizie dalla busware al ritorno dalle ferie.

Alla fine avevo cercato un'interfaccia gia' fatta a cui collegare i fili dei contatori e nulla piu', ma ho risolto la verifica dei conteggi collegandomi direttamente al gpio del raspberry con qualche resistenza e piccoli circuiti autocostruiti da pochi euro :-)

Grazie ancora

Ciao

Eugenio

 

 

Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ci sono attualmente 16 utenti e 73 visitatori collegati.

Ultimi Commenti