Home
Accesso / Registrazione
 di 

Led che si accendono con segnale 0-10v

23 risposte [Ultimo post]
ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13

Ciao,
sto cercando di realizzare un circuito per accendere 4 led utilizzando una tensione 0-10v, in pratica con 2.5v vorrei accendere il primo led, con 5v il secondo, con 7,5v il terzo e con 10v il quarto, all'accensione di quest'ultimo però, si dovrebbero spegnere gli altri 3.
Ho già fatto un circuitino utilizzando dei diodi zener (da 3.9-5.6-6.7) e delle resistenze per accendere i led, ma non so come fare per fare in modo che all'accensione del quarto si spengano gli altri tre...
Mi potete dare qualche suggerimento? considerando che non sono molto pratico... :)
Grazie

bye bye

ritratto di Emanuele
Online
Titolo: Moderator
Moderatore
Ultima visita:
15 min 2 sec fa
Utente dal: 28/07/2007
Messaggi: 1009
Utente PREMIUM
Accensione led

Si potrebbe fare in vari modi.

Partendo dal circuito che hai già realizzato
(tutti i led si accendono come desideri ma non si spengono i primi 3 all'accensione del 4)
potresti abbinare all'accensione del quarto un transistor che, attraverso un altro transistor alimenta gli altri 3, ovviamente dovrai separare le alimentazioni. Il quarto led alimentato direttamente , invece gli altri tre alimentati tramite il suddetto transistor (o mosfet).

Oppure potresti giocare un po con le porte logiche
http://it.wikipedia.org/wiki/Porta_logica

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Grazie per l'interesse, avevo

Grazie per l'interesse, avevo immaginato che avrei potuto usare dei transistor, quindi ne basterebbero due, se ho capito, uno all'ingresso dell'alimentazione (che poi va direttamente al 4 led) e l'altro per gli altri 3. Non essendo pratico, mi potresti indicare praticamente come dovrei collegare anche i relativi piedini? :)
Ancora grazie

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
LM3914 con 4 led

Oppure prova con questo
http://www.webalice.it/crapellavittorio/schemivari/LM3914_4led.gif
con 10V in ingresso regoli il trimmer per avere L4 acceso
poi verifichi gli altri valori ma dovrebbe essere ok

ritratto di Emanuele
Online
Titolo: Moderator
Moderatore
Ultima visita:
15 min 2 sec fa
Utente dal: 28/07/2007
Messaggi: 1009
Utente PREMIUM
LM3914

Il 3914 è sicuramente una soluzione più 'pulita' rispetto agli zener.
Il doppio transistor npn - pnp è proprio la soluzione che avevo in mente. Si usa spesso per staccare l'alimentazione principale quando serve (con un mosfet al posto del pnp)

Facci sapere...

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Il problema del 3914, che

Il problema del 3914, che avevo visto in rete ma con 10led, è che necessita di un'alimentazione 12v separata, che nel mio caso non ho, posso al massimo utilizzare una 24v ac/dc
Ma dite che solo con gli zener e i transistor non sarebbe affidabile?

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
Dipenda da che precisone vuoi

Dipenda da che precisone vuoi nel riconoscimento..
con soli zener e transistori devi fare i conti con le derive termiche

Certo che se si sapessero tutti i preamboli del problema si arriverebbe prima alla soluzione..
Bisogna sempre più che chiedere soluzioni raccontare bene cosa si ha e cosa si vorrebbe

Ma la stessa tensione da controllare accende pure il led ?

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Hai ragione. Si, vorrei con

Hai ragione.
Si, vorrei con la stessa tensione accendere direttamente anche i led, avendo in loco solo una 24v per una potenziale alimentazione.
Vorrei inoltre qualcosa di economico e poco ingombrante, quello attuale l'ho fatto all'interno di un copriforo, da mettere poi in una 503 (per capirci).
http://imageshack.us/photo/my-images/820/dsc00223zv.jpg
Inoltre, le tensioni di accensione dei 4 led, le posso gestire a mio piacimento (tramite un controllore), quindi non sono vincolato a valori fissi, ma fatte le opportune prove, poi posso impostare i valori precisi di funzionamento.
Spero di essere stato un po piu chiaro.
Grazie per la pazienza ;)

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
Ti potrà sembrare strano ma è

Ti potrà sembrare strano ma è difficile comprendere che con la stessa tensione vuoi accendere anche i led ma poi dici che le tensioni di accensione dei 4 led le gestisci con un controllore ma le soglie le fai con dei diodi zener...
Forse se mi fosse chiaro tutto il tuo progetto e magari lo schema di quello che hai fatto e a cosa servono i led mi verrebbe più semplice trovare una soluzione.
Se come l'hai fatto ti soddisfa ma ti manca solo lo spegnimento dei primi 3 quando si accende il 4°, allega lo schema tuo così vedo cosa inserire per ottenere quanto vuoi.

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Mi sarò espresso male, cmq il

Mi sarò espresso male, cmq il mio scopo è con un'unica uscita 0-10v di un controllore (non ne ho altre) accendere 4 led che indicano diversi stati (3 velocità di un ventilatore + automatico). Per farlo attualmente ho usato questo schema (spero si capisca ma sono a letto influenzato):
http://img835.imageshack.us/img835/8787/dsc00226ac.jpg
A lato ho indicato i diversi valori a cui si accendono i 4 led.
Attualmente volendo accendere il quarto led (posizione 'automatico') si accendono anche gli altri tre, cosa che vorrei evitare.
Sono soodisfatto dei primi 3 led, ma non so se il circuito è affidabile, ovvero che non si bruci dopo poco tempo...
Grazie per la collaborazione.

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
LED ora chiaro

Ora sì è chiaro a cosa serve e cosa vuoi fare
Una soluzione potrebbe essere questa

Io suggerirei l'aggiunta di tre FET che indipendentemente dalla tensione mantengono costante la corrente che scorre nel led se possibile il fet dovrebbe essere un BF245C
ma va bene anche un 2N3819. Lo zener 3V9 valuta se meglio 3V3.

Il trimmer potrebbe anche non essere indispensabile, potrebbe bastare una R fissa da 220 Ohm e la base va tra la R e il led.

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Grazie, credo mi sia tutto

Grazie, credo mi sia tutto chiaro, appena riesco a comprare i componenti provo a farlo e ti faccio sapere.

bye bye

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Al momento non sono ancora

Al momento non sono ancora riuscito a trovare i componenti (in zona non li hanno, e sto ancora influenzato), nel frattempo ho fatto un layout costruttivo su una millefori, credo sia corretto, ma visto che non è il mio campo, potrei aver fatto anche qualche errore glossolano... :(
Ho cercato di ottimizzare le saldature (in rosso), e portare al minimo i 'ponticelli' (in verde):

http://img853.imageshack.us/img853/1501/schema4ledrev01.jpg

Grazie ancora

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
PCB 4 LED

Ma sotto i componenti le piste ci possono passare senza bisogno di ponticelli
in pratica nella tua soluzione c'è bisogno solo di un ponticello il resto è fattibile solo con piste..
Io lo modificato come vedi qui sotto e ho girato il FET perchè non erano corretti
sempre che quello che si vede sia il lato componenti

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Ah, dopo lo riconfronto con

Ah, dopo lo riconfronto con lo schema per cercare di capire gli errori ;)
Io avevo messo dei ponticelli, perchè utilizzando una millefori, come faccio a creare la pista al lato di sotto? utilizzando stesso i tranci dei piedini dei componenti (o qualcosa di analogo)?
Ho notato che hai anche cambiato due resistenze, è necessario? Solo perchè quelle precendenti (1200 e 2700) le ho appena ordinate online...
Grazie sempre per la disponibilità

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
Mille fori

Per le R va bene anche quelle ordinate ..
per la mille fori sì fin dove arrivano usi gli stessi teminali dei componenti sagomati ancora prima di essere saldati, poi prosegui con dei pezzi di filo

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Fatto, ma...

Ciao,
ho fatto il circuitino, è venuto un po affollato, credo che poi dovrò rifarlo su una piastra un po più grandicella, ma il problema principale è che non si accendono i led :(
Ho rivisto più volte il circuito rispetto allo schema e combacia.

http://img252.imageshack.us/img252/5287/dsc00235ip.jpg

Provando con diverse tensioni fino a 10v, nessun led si accende; ho notato però, con un tester, che sui led arrivano tensioni con il polo scambiato (+ al posto del -) tant'è che se ci appoggio un uteriore led con i piedini invertiti, questo si accende. Si accendono però sempre, ovvero con i 10v, invertendo i led, si accenderebbero tutti e 4 (ho provato sempre aggiungendo un ulteriore led sugli stessi piedini).
Da cosa pensi possa dipendere?
Grazie ancora

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
4 led

Mi sa che hai invertito pure gli zener oltre i led
nei diodi la parte segnata con la fascetta nera è il catodo e gli zener hanno il catodo rivolto verso il positivo

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Allora provo a girare i led,

Allora provo a girare i led, nello schema erano inversi rispetto agli zener, questi ultimi sono già verso il positivo.
Ti faccio sapere come va, grazie

bye bye

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Funziona!!

Ho invertito i led, ed ora funziona alla perfezione! :)
Ho provato con un alimentatore con le uscite variabili, domani provo direttamente con il controllore cmq sembra tutto funzionare alla perfezione!
Grazie mille per la collaborazione

bye bye

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Il controllore nn ce la fa...

Provando direttamente con l'uscita del controllore, invece, non si riesce ad accendere il quarto led, ed anche il terzo è abbastanza fioco... :(
Ho notato che se dal controllore escono 10v (misurati con tester), quando poi collego il circuitino questi si abbassano a 7,4v il che mi fa pensare ad un problema di assorbimento.
Misurando con un tester (elettronico) risulta un assorbimento di 1,5A, ma non so se è affidabile come dato, ed in effetti l'uscita del controllore è max 700mA.
C'è modo di farlo un po più "leggero"?

Grazie ancora

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
Scusa ma come hai fatto a

Scusa ma come hai fatto a misurare la corrente ?
mettendo il tester tra uscita e massa ?

Se hai fatto in quel modo quella è la corrente di corto circuito...

Quel circuito a led se funziona deve assorbire assimo massimo 40/50 mA

Per vedere cosa assorbe in corrente il tester mettilo in serie tra l'uscita + del PLC
e il + d'ingresso del circuito .. poi riferisci

Ma le carattristiche di uscita del PLC quali sono ?

ritratto di frjariello
Offline
Titolo: User+
Utente+
Ultima visita:
2 anni 7 settimane fa
Utente dal: 12/02/2012
Messaggi: 13
Leggendo meglio le

Leggendo meglio le caratteristiche dell'uscita del plc, in realtà l'uscita 0-10v è max 23mA, (i 700mA erano invece per l'uscita ausiliaria 24v).
Dovendolo per forza installare venerdi, ho fatto (per ora) una modifica, utilizzando solo la parte del circuitino per i primi 3 led, mentre il quarto l'ho collegato con due resistenze (2700+1200 quelle che avevo...) sulla 24v interrotta da un'uscita digitale del plc.
Essendo riuscito a recuperare un'uscita digitale il quarto led potrebbe anche restare cosi. Però anche solo con 3 led, resta un'abbassamento di tensione che sicuro non fa bene al controllore, nè alla stabilità del circuito.
Considerando che questo è il led (verde) https://www.distrelec.it/ishop/Datasheets/ruL-7113LGD_data_e.pdf che resistenza dovrei mettere per farlo accendere a 24v? a me venivano valori intorno ai 12kohm...

Questi invece sono quelli gialli https://www.distrelec.it/ishop/Datasheets/ruL-7113LGD_data_e.pdf

Grazie

bye bye

ritratto di Vittorio Crapella
Offline
Titolo: PowerUser
Utente Power
Ultima visita:
9 settimane 1 giorno fa
Utente dal: 21/09/2011
Messaggi: 281
R led

R = (Valim - Vled)/ Iled
in genere bastano 10 mA pertanto R = (24 - 2 ) 10 = 2,2 KOhm

Se i led si illuminano bene puoi auemntare le R in serie per abbassare la corrente
così da non sovraccaricare l'uscita del PLC

 

 

Visita il sito EOS-Book con centinaia di progetti ed articoli!

Visita il nuovo sito di EOS-Book
Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ci sono attualmente 18 utenti e 57 visitatori collegati.

Ultimi Commenti