Home
Accesso / Registrazione
 di 

Problema Arduino sensore Temperatura

1 risposta [Ultimo post]
ritratto di vincenzo.gis
Offline
Titolo: User
Utente
Ultima visita:
2 settimane 3 giorni fa
Utente dal: 31/03/2013
Messaggi: 6
Utente PREMIUM

Salve Ragazzi,
avrei bisogno del vostro aiuto gentilmente.

Sto facendo un po di pratica con arduino, ma ho dei problemi.
In particolare il mio sensore di temperatura TMP36, da un valore di temperatura continuamente oscillante, e in particolare ho notato che lo fa quando gli altri led (che uso per altri sensori, Pir, Fotoresistenza) si accendono. Ho provato a mettere un condensatore di 0.1uF in parallelo all'alimentazione del sensore come scritto sul datasheet ma ancora non sono riuscito a risolvere.

Voi per caso avete in mente qualcosa per questo problema??.

Grazie in anticipo per il Vostro Aiuto :)

ritratto di vincenzo.gis
Offline
Titolo: User
Utente
Ultima visita:
2 settimane 3 giorni fa
Utente dal: 31/03/2013
Messaggi: 6
Utente PREMIUM
Problema PIR e Fotoresistenza

Grazie Ragazzi ma con il sensore di temperatura ho risolto sostituendolo con il digitale dsb1820, ma ora mi rimane il problema per il sensore PIR, e la fotoresistenza per la luminosità.

In sostanza ogni volta che accendo un led, cominciano ad oscillare sia i valori della fotoresistenza, sia i valori del PIR (true / false).

Io non so quindi se è un problema di assorbimento di correnti oppure di interferenza elettromagnetica, comunque vi dico che il tutto è stato fatto su una piccola protoboard.

Avreste altri consigli da darmi??...probabilmente dovrei provare a stabilizzare le correnti e tensioni a monte, ma non so come fare potreste aiutarmi?? grazie mille

 

 

Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ci sono attualmente 3 utenti e 33 visitatori collegati.

Utenti online

Ultimi Commenti