Home
Accesso / Registrazione
 di 

Problemi file Gerber in KiCAD

5 risposte [Ultimo post]
ritratto di delfino_curioso
Offline
Titolo: User++
Utente++
Ultima visita:
10 ore 18 min fa
Utente dal: 01/09/2012
Messaggi: 95
Utente PREMIUM

Ciao ragazzi,
sto avendo problemi nella generazione di file Gerber per la produzione di PCB mediante macchine CNC.
Una volta disegnato il circuito con KiCAD ed ottenuto il file .kicad_pcb del master, dal Tracciatore creo il relativo file .gbl dello strato "Bottom" del circuito.
Usando successivamente dei software per la conversione da Gerber a G-Code (al momento uso in particolare "PCBMill" - http://www.cncdrive.com/content/PCBMill.htm) il processo si arresta sempre a causa di un "erroneo formato di dati in ingresso".
Sapete se c'è qualche noto problema di KiCAD nella generazione dei file Gerber? Per caso KiCAD usa un formato specifico che non si attiene allo standard RS-274X?
Grazie,
ciao

ritratto di Piero Boccadoro
Offline
Titolo: Moderator
Moderatore
Ultima visita:
9 ore 31 min fa
Utente dal: 28/06/2011
Messaggi: 878
Utente PREMIUM
Che io sappia no ma sto

Che io sappia no ma sto cercando in giro su internet.... se trovo qualcosa te lo faccio sapere :)

ritratto di Piero Boccadoro
Offline
Titolo: Moderator
Moderatore
Ultima visita:
9 ore 31 min fa
Utente dal: 28/06/2011
Messaggi: 878
Utente PREMIUM
Ho visto

Ho visto questo
http://code.google.com/p/opendous/wiki/KiCADTutorialCreatingGerberFiles
ma non sembra che ora sia diverso...
Hai dato uno sguardo a questa discussione qui?
http://www.eevblog.com/forum/open-source-kicad-geda/what-exactly-is-wrong-with-kicad%27s-g...
Mi sembra un caso un po' diverso, a dire il vero...

ritratto di delfino_curioso
Offline
Titolo: User++
Utente++
Ultima visita:
10 ore 18 min fa
Utente dal: 01/09/2012
Messaggi: 95
Utente PREMIUM
Ciao Piero, grazie per le

Ciao Piero,
grazie per le risposte.
Il secondo link lo avevo già visitato , ma non mi ha portato a risolvere il problema.
Girando un po' per la rete ho visto addirittura un tizio che per risolvere questo problema propone di esportare il .brd in Gerber, aprirlo nel gerber viewer e poi esportare "al contrario" il Gerber in .brd . Veniva passato come un valido workaround, ma anche stavolta non ho avuto successo.
A questo punto ho provato a rifare lo stesso circuito con Eagle e, dopo l'esportazione in Gerber, di nuovo stesso problema. Ho dunque pensato che potesse essere o un problema del software PCBMill o il mio circuito fatto male. Ma, quanto alla seconda, una volta aperto il gerber con un visualizzatore, quello che appare è esattamente il master creato.
Credo che farò delle prove con dei circuiti elementari sperando almeno di capire dove NON sta il problema...

ritratto di Piero Boccadoro
Offline
Titolo: Moderator
Moderatore
Ultima visita:
9 ore 31 min fa
Utente dal: 28/06/2011
Messaggi: 878
Utente PREMIUM
Temo non ti sia rimasta

Temo non ti sia rimasta alternativa.
Se vuoi possiamo provare una cosa: mandami i file e vediamo se anche io ho il problema.
Un'idea striminzita davvero ma alla fine una vale l'altra, visto come stanno le cose. No?

ritratto di delfino_curioso
Offline
Titolo: User++
Utente++
Ultima visita:
10 ore 18 min fa
Utente dal: 01/09/2012
Messaggi: 95
Utente PREMIUM
Concordo. Quanto prima ti

Concordo.
Quanto prima ti invio il gerber creato.
Se invece di PCBMill hai un tuo programma di generazione del G-code di fiducia, usa pure quello: se tutto funziona valuterò eventualmente di passare al tuo.
Grazie per la disponibilità, ciao ;-)

 

 

Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ci sono attualmente 2 utenti e 44 visitatori collegati.

Utenti online

Ultimi Commenti