Home Forum ELETTRONICA GENERALE “Rientro” su massa

Questo argomento contiene 6 risposte, ha 4 partecipanti, ed è stato aggiornato da  fra83 3 anni, 5 mesi fa.

Stai vedendo 7 articoli - dal 1 a 7 (di 7 totali)
  • Autore
    Articoli
  • #57526

    temuccio
    Membro

    Ragazzi,
    cerco suggerimenti per quanto segue.
    Ho un dispositivo che mi tira fuori, su un piedino, un allarme semplicemente fornendomi una massa. Io vorrei comandare un carico con questo allarme e quindi ho pensato di interfacciarmi con un relè, effettuando questo collegamento:

    • Vcc(12V) collegati al pin positivo del controllo relé
    • Massa del controllo relé collegato al dispositivo

    Inoltre ho inserito un pulsante NA in parallelo a questo segnale di massa (un contatto in parallelo all’uscita del dispositivo, un altro a massa) per bypassare il dispositivo e far scattare il relé.
    Con questo collegamento tutto sembra funzionare bene ma dopo alcuni giorni ho un guasto sul dispositivo.

    Ho quindi effettuato una misura ed a vuoto (quindi con dispositivo senza allarme) ho una tensione tra massa del sistema e pin di allarme pari a 12V.
    Secondo voi da cosa dipendono questi guasti? Il relé assorbe più corrente di quella che può sopportare il dispositivo (di cui non conosco le specifiche)?
    Potrei staccarlo fisicamente inserendo un optoisolatore (e quindi comandando il relé con una corrente minore evitando i guasti)?
    Grazie

    #68989

    lux1982
    Membro

    hai provato a verificare che non ci siano cortocircuiti invlontari? a volte la risposta ce l’hai sotto al naso e non te ne rendi conto.

    #68990

    temuccio
    Membro

    Il realtà il relè si chiude in due casi:

    1. allarme sul dispositivo
    2. pressione del pulsante

    se ci fossero cortocircuiti involontari dovrei sentirlo scattare. L’unica cosa di cui sono sicuro è che manca il diodo montato in controparallelo sul relé, che potrebbe comportarmi degli spike e la rottura del dispositivo

    #68991

    i guasti riguardano il dispositivo o il relè?
    di che dispositivo si tratta?
    Sei sicuro che la corrente che viene assorbita nel circuito che hai realizzato sia compatibile sia col dispositivo che con il relè?
    usando un optoisolatore potresti ovviare al problema, ma devi sempre verificare che anche in questo caso le correnti siano compatibili tra di loro.
    Comunque un guasto a distanza di qualche giorno potrebbe indicare qualcosa di sbagliato, ma non troppo. mi spiego meglio: se avessi fatto scorrere su una resistenza più corrente di quanta questa può gestire, la resistenza avrebbe preso fuoco (letteralmente!) a breve. Se invece fai scorrere mettiamo 45mA su una porta logica che ne può erogare 40, probabilmente ci mette più tempo a danneggiarsi, ma è molto probabile che prima o poi succeda. questo potrebbe essere il nostro caso. prova a effettuare qualche misura di corrente nel circuito, anche se non è molto comodo, e vedi se c’è qualcosa che non va.
    Se non conosci le specifiche del dispositivo comunque è difficile riuscire a isolare il problema… magari se ci dici di che cosa si tratta possiamo aiutarti!
    Tra le varie cose che potresti provare, oltre l’optoisolatore, più semplicemente puoi provare a usare un transistor per fornire corrente.
    facci sapere!

    #68992

    temuccio
    Membro

    Il dispositivo è un sistema di motion detection su un encoder: praticamente prende un segnale video da una sorgente ed in caso di movimento mi attiva il relé. Con l’interruttore posso anche scegliere di attivare il relé senza aspettare il movimento. Il problema è che se apro il sistema di motion detection ne perdo la garanzia :(
    Putroppo non saprei dove reperire le specifiche dato che il produttore non le fornisce ed online non trovo nulla. Considerato che ho già rotto un elevato numero di dispositivi, vorrei cercare una soluzione un pochino duratura e per questo mi sono buttato verso un optoisolatore

    #68993

    si, diciamo che in questo caso l’optoisolatore ci sta tutto. ben fatto. Comunque prova anche a mettere il diodo di protezione al relè, e magari anche una capacità, gli scatti repentini di tensione non fanno bene a nessuno… Comunque se hai già rotto dei dispositivi, se non vale la garanzia in quel caso, potresti aprirli per capire meglio con cosa hai a che fare, o no?

    #69096

    fra83
    Membro

    ti consiglio diodo di ricircolo sulla bobina del relè e disaccoppiamento elettrico con l’optoisolatore, dal punto di vista logico il tuo circuito è corretto però in questi casi bisogna vedere bene le caratteristica dek dispositivo e anche del relè che stai usando.

Stai vedendo 7 articoli - dal 1 a 7 (di 7 totali)

Devi aver eseguito l’accesso per poter rispondere a questa discussione.