Home
Accesso / Registrazione
 di 

Salve a tutti! Sono nuovo del forum...

3 risposte [Ultimo post]
ritratto di Emilio1980
Offline
Titolo: User
Utente
Ultima visita:
1 anno 23 settimane fa
Utente dal: 06/04/2012
Messaggi: 2

e semi-nuovo anche in elettronica... sperando di poter essere utile a voi almeno nell'informatica, anche se ho programmato poco a basso livello, avrei uno strano quesito da porvi?
Sto giusto "provando" a costruire un robot, lo so che uno dovrebbe prima mettersi di sana pianta a studiare la teoria, ma alla fine mi piace tanto provare e siccome è solo un hobby l'importante è che mi diverto ;-)
Come prima cosa ho raccattato dei motori passo passo dallo sfattino e non so minimamente i loro dati tecnici tanto meno sono riuscito a trovare datasheet o informazioni su tali motori, cmq ho pensato: "proviamo e vediamo che ne esce"...
Bhe ne è uscito tanto alla fine ma andiamo per passi...
l'elettronica che ho usato è composta da due schedine cinesi per pilotare ciascuna un motore stepper (o due DC) con un assorbimento massimo di 2A per fase ed ho collegato i segnali di uscita alla parallela del pc (tanto basta che sia alto o basso il segnale)

Prima prova:
Preso un alimentatore da 12V e 2A (più o meno), il motore gira che è una bellezza anche con controllo high torque e con una velocità, se può essere utile, di 10 ms a fase.

Qui subentra l'entusiasmo...

Seconda prova:
dopo aver costruito un minimo di telaio, attaccato i motori e due ruote,
ho preso una batteria al piombo 12V 3,5A (vecchia come il cucco, quindi non so se eroga il massimo), la base si muove, a fatica ma si muove... la fatica era anche data dal fatto che i mozzi non erano stretti bene sull'albero motore (me ne sono accorto dopo).

Siccome alla batteria c'è attaccato anche un computer a basso consumo il tutto è durato moooolto poco, da considerare anche il fatto che il peso complessivo del robot potrebbe superare i 10Kg

Ormai sono in estasi :-D

Terza prova:
Solita batteria, ma questa volta il pc alimentato alla presa con un filo lungo; la piattaforma si muove sempre a fatica (non avevo ancora controllato i mozzi) però meno di prima, soprattutto alla partenza (dove penso ci sia un gran consumo)

Qui subentra il disastro :-D :-D

Quarta ed ultima prova, ultima per ora ;-)
Visto che l'ho visto camminare ho pensato che era arrivato il momento di spendere qualcosa soprattutto nella batteria, quindi ho comprato nuova una batteria da 12V 18A, ho assemblato tutto ed ho fatto la prova su una specie di ponte perché mi ero accorto del problema dei mozzi ma non avevo la brugola per avvitarli.
Morale della favola? Finché non ho dato la velocità massima e il high torque tutto bene, i motori giravano... poi, prima di andare per strada si sa che si deve fare un test di stress... bene! velocità 10ms a fase in high torque, il ponte h sulla schedina ha resistito per una 30ina di secondi per poi schizzare a 200mila all'ora sul soffitto per quanto bruciava :-D :-D (non scherzo è davvero schizzato via un pezzo del componente)

Prima che nella quinta prova mi porto via un occhio, ho pensato di iscrivermi a questo forum e chiedere un parere:
C'è un modo per sapere quanto consuma un motore? Nel senso che io credo che il componente si sia rotto (correggetemi se dico cavolate) perché il motore ha detto: "devo andà a palla, mi serve corrente" e a questo giro la batteria a detto: "aaa ne voi di più di 2A, certo io ne ho 18" (per farla carina) :-D solo che sul datasheet della schedina c'era scritto chiaro il limite dei 2A e quando ne sono passati di più se l'è presa a male (permalosa); questa corrente in più mi piacerebbe scoprire quant'è; però forse non è tanto lontano da 2A altrimenti sarebbe esploso subito e non dopo un pochino...
Altrimenti, se non c'è modo di sapere quanto consuma il motore, secondo voi, posso comunque ridimensionare l'elettronica di controllo per andare ad esempio a 6A massimo in modo da essere sicuri di rientrarci??? per la costruzione non ci dovrebbero essere problemi, ho già costruito 4 piccoli ponti H per pilotare un motore passo passo da arduino, credo basti dimensionare i transistor e le resistenze in maniera opportuna, no?? Magari dissipando a bestia.
So che penserete che ho solo una gran confusione in testa, ma va bene così col tempo apprendo ;-) e se non apprendo continuo ad andare a caso :-D :-D

Grazie in anticipo a tutti ;-)

ritratto di Emanuele
Offline
Titolo: Moderator
Moderatore
Ultima visita:
54 min 2 sec fa
Utente dal: 28/07/2007
Messaggi: 1022
Utente PREMIUM
Motori passo passo per Robot

Ciao Emilio,
benvenuto!

Complimenti per il tuo entusiasmo, da vero Maker!

Direi che prima di tutto dovresti accertarti della qualità del motore passo passo, potrebbe aver ceduto lui ed entrato in corto circuito.

Poi lavorare su uno schema elettrico che oltre a pilotare il passo-passo gestisca anche gli assorbimenti e quindi regoli la corrente. Se utilizzi Arduino è tutto fattibile.

Facci sapere!

ritratto di Emilio1980
Offline
Titolo: User
Utente
Ultima visita:
1 anno 23 settimane fa
Utente dal: 06/04/2012
Messaggi: 2
Ma se fosse entrato in corto

Ma se fosse entrato in corto il motore, dopo non dovrebbe più funzionare per niente, giusto? perché dopo aver schiantato la schedina ho provato cmq ad usarla e due segnali andavano ancora eccitando il motore anche se chiaramente non ruotava.

Quindi mi stai dicendo che costruire dei ponti h con transistor e resistenze dimensionati a dovere non basta?

Grazie per l'interesse...

ritratto di Emanuele
Offline
Titolo: Moderator
Moderatore
Ultima visita:
54 min 2 sec fa
Utente dal: 28/07/2007
Messaggi: 1022
Utente PREMIUM
Non hai feedback... Penso il

Non hai feedback...

Penso il problema principale sia capire l'affidabilità dei motori che ha recuperato.

Un circuito con controllo in corrente andrebbe sempre fatto a livello professionale, nel tuo caso perche non sai se il motore è affidabile....

 

 

Login   
 Twitter Facebook LinkedIn Youtube Google RSS

Chi è online

Ci sono attualmente 5 utenti e 20 visitatori collegati.

Ultimi Commenti